x
Highlighted
CagriCaymaz

CreateCustomerCard Not working

Hi, I am having an issue with API on production.I want to explain the process that I am using in my system.

 

I create a customer and then create a card into this customer. Everything is working under sandbox but when I switch it back to production, I got an error. I want to give you my tracking values. I got them in my system.

 

 

/*Creating Customer Area*/
2017-01-11 10:48:59.0152 CreateCustomer-BEGIN :
Parameters : userId=260, email=cagri@modobay.com, name=Cagri Caymaz
2017-01-11 10:48:59.3121 CreateCustomer-END :
Response customerId=MQNVYJ7TBS16MG1WTCVJJW8TC0
 
/*Creating Card Area*/
2017-01-11 10:48:59.3121 CreateCard-BEGIN :
Parameters : customerId=MQNVYJ7TBS16MG1WTCVJJW8TC0, cardNonce=CBASEE5Dxv_YCMv3TIGTHyuaiS0gAQ, cardHolderName=Cagri Caymaz
2017-01-11 10:48:59.4997 CreateCard-ERROR :
Response Error calling CreateCustomerCard: {"errors":[{"category":"INVALID_REQUEST_ERROR","code":"NOT_FOUND","detail":"Resource not found.","field":"card_nonce"}]}

 

As you can see, i have created customer. I do have card nonce from payment form. But i cannot create customer card. CreateCustomer and CreateCard are different 2 methods. 

 

I didnt understand what is going on.

 

Can you help me?

Tags (1)
Message 1 of 4
140 Views
3 Replies
Admin

Re: CreateCustomerCard Not working

Can you share some of the code that generated that output? 

Message 2 of 4
121 Views
CagriCaymaz

Re: CreateCustomerCard Not working

I just fixed :) Sql-payment method was using sandbox key. :) everything is working well :)

Message 3 of 4
118 Views
Admin

Re: CreateCustomerCard Not working

:)

Message 4 of 4
108 Views