x
Highlighted
kic1

Logo not showing on Email Collection Form

On Email Collection form, Hosted Signup Page, I am not able to add my logo on the Customize page. It is grayed out even though I did set up the logo in the Receipt page (which is where the Business Settings link takes me to).  Is there another place to add a logo that this "Customize" page is looking for?  

hosted signup page.JPGcustomize signup.JPG

Message 1 of 6
53 Views
1 Best Answer

Accepted Solutions
Admin

Re: Logo not showing on Email Collection Form

Best Answer

Thanks Lisa!

 

Hmm, do you have more than one active location? If you created another location (or other locations) but you're not using it yet, can you try adding the logo under Branding to that location as well to see if it works? 

Message 4 of 6
27 Views
5 Replies
Admin

Re: Logo not showing on Email Collection Form

@kic1 Thanks for brining this to my attention. It looks like the link is taking you to the Receipt section but you also need to add your logo to your Location Details. Can you try these steps? 

  1. From your online Square Dasboard navigate to Account & Settings.
  2. Click Business > then click Locations.
  3. Click on the name of your location > scroll down to add your logo under Branding > click Save.
  4. Repeat for any other locations.

When you've followed these steps you should be able to enable the Display Logo setting. I've also reported this to the Dashboard team so that we can update the message/link to direct you to the right place. Thanks again! 

Message 2 of 6
36 Views
kic1

Re: Logo not showing on Email Collection Form

Hi Helen,

 

Thanks for your reply.  There must be some kind of bug here, because I have added logos to the location in the Branding page, and still the toggle switch for adding logo to the Email Collection page is disabled.

 

Best regards,

Lisa

Message 3 of 6
32 Views
Admin

Re: Logo not showing on Email Collection Form

Best Answer

Thanks Lisa!

 

Hmm, do you have more than one active location? If you created another location (or other locations) but you're not using it yet, can you try adding the logo under Branding to that location as well to see if it works? 

Message 4 of 6
28 Views
kic1

Re: Logo not showing on Email Collection Form

Thank you Helen, that did the trick.

Message 5 of 6
26 Views
Admin

Re: Logo not showing on Email Collection Form

Wonderful, thank you for your patience today!

 

As I mentioned I've escalated this to the Dashboard team so we can make these steps clearer/better. Thanks again! 

Message 6 of 6
24 Views