x
Beta Member

Reader won’t pair. Update required

Hi I have an iPad air 4th generation. When I pair a contactless & chip reader, it says update requires. Please update Point of Sale.

Both the device & the Square App are updated

Message 1 of 7
104 Views
6 REPLIES 6
Beta Member

I have this problem too - my iPad and iPhone are running ios beta versions. My old iPhone is running the latest public non-beta version and it can connect ok. 

Message 2 of 7
86 Views
Admin

Hey @VikBingley and @cam_inc,

 

I can confirm this is definitely an issue with the 14.5 iOS Beta. The issue will be resolved once iOS14.5 goes live, however for now in order to continue using Square reader you'd unfortunately need to roll back to the public 14.4 release!

Seamus
Community Manager, Square
Sign in and click Mark as Best Answer if my reply answers your question.
Message 3 of 7
85 Views
Beta Member

Thanks, Seamus - The support team sent me another reader last week because we could not get my old one working - I've opened the replacement one and had the same error and then ended up here. what should I do with it? 

Message 4 of 7
84 Views
Admin

Hey @Cam-inc,

 

The issue here unfortunately is the iOS14.5 Beta, not the reader - you'll need to roll back to iOS 14.4 in order to use Square Readers!

 

You can find instructions on doing this via the Apple website.

Seamus
Community Manager, Square
Sign in and click Mark as Best Answer if my reply answers your question.
Message 5 of 7
81 Views

I had the same problem.  I reinstalled the square app, removed thereader from my bluetooth devices and then paired starting from bluetooth under settings.  It worked!

 

Message 6 of 7
26 Views

Hi Heather! Thanks for the info, I think I did try that, but it was a while ago now and cant really remember. After a later beta iOS update, it fixed itself. 

Message 7 of 7
23 Views